HDU 1397 Goldbach's Conjecture(素数判断)

Goldbach's Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5692    Accepted Submission(s): 2204

Problem Description
Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
 
Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 

Output
Each output line should contain an integer number. No other characters should appear in the output.
 
Sample Input
  
  
6 10 12 0
 
Sample Output
  
  
1 2 1
 
Source
 
AC代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
int s[65536]={0};
int main()
{
	int i,j,ans;
    for(i=2;i<=65535;i++)
    {
        for(j=2;j<=sqrt((double)i);j++)  //素数打表,不是素数的就是0
            if(i%j==0)
                break;
        if(j>sqrt((double)i))
            s[i]=i;
    }            
    int n;
    while(scanf("%d",&n)&&n)
    {
        for(ans=0,i=2;i<=n/2;i++)
        {
            if(s[i]!=0&&s[n-i]!=0) //判断顺向和逆向,比如10=7+3=3+7 
                ans++;
        }
        printf("%d\n",ans);    
    }
    return 0;
}

AC:素数筛选
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
#define N 65536

int pri[N];

int main()
{
	int i,j,m,n,g,t,d,k;
	int cnt,a,b,c;

	memset(pri,0,sizeof(pri));

	for(i=0;i<N;i++)
		if(i%2)
			pri[i] = 1;
	pri[2] = 1;

	for(i=3;i<=sqrt(N);i++)
		if(pri[i])
		{
			for(j=i+i;j<N;j+=i)
				pri[j] = 0;
		}

	while(cin>>n,n)
	{
		for(i=2,cnt=0;i<=n/2;i++)
		{
			if(pri[i]==0)
				continue;
			if(pri[n-i])
				cnt++;
		}

		cout<<cnt<<endl;
	}
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值