HDU 1597 find the nth digit (数学题)

find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11282    Accepted Submission(s): 3372

Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 
Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。

Output
对于每个N,输出S中第N个对应的数字.

Sample Input
  
  
6 1 2 3 4 5 10

Sample Output
  
  
1 1 2 1 2 4

Author
8600

Source

题解:数学题,模拟一下即可。

AC代码:
#include<stdio.h>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL; 
LL a,b;
int main()
{
    scanf("%lld",&a);
    while(a--)
    {
    	
        scanf("%d",&b);
        LL n=1;   //每输入一个就从S1开始模拟,找出 b 在的Sn。 
        while(b>n)  //模拟 
        {
            b-=n;   
			n++;
        }
      //  printf("%d\n",b);
	if(b%9==0)
		printf("9\n");
	else
		printf("%lld\n",b%9);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值