Nested Dolls(hdu1677(LIS))

/*
http://acm.hust.edu.cn/vjudge/contest/view.action?cid=28195#problem/E
http://acm.hdu.edu.cn/showproblem.php?pid=1677
Nested Dolls
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
 
Practice
 
HDU 1677
Description
Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?
 
Input
On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.
 
Output
For each test case there should be one line of output containing the minimum number of nested dolls possible.
 
Sample Input
4
3
20 30 40 50 30 40
4
20 30 10 10 30 20 40 50
3
10 30 20 20 30 10
4
10 10 20 30 40 50 39 51
 
Sample Output
1
2
3
2
解析:
题意:可以这样理解为给出若干个盒子的高度w和宽度h,如果wi>wj&&hi>hj,则j可以嵌在i里面。问最终组装好的之后变成几个箱子
思路:最长上升子序列问题
注意:1.这由于涉及到两个因素,因此可以先对盒子的宽度进行由大到小排序并且在宽度相同的情况下其高度按照从小到大的顺序排序。
   2。然后只针对求高度最长上升序列,由于数据比较大,则要用二分法进行查找和排序


Accepted 464 KB 78 ms C++ 731 B
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include <iostream>
using namespace std;
const int N=20000+5;
struct doll
{
	int w;
	int h;
}d[N];
int dp[N];//储存排序结果
bool cmp(doll d1,doll d2)
{
	return d1.w>d2.w||(d1.w==d2.w&&d1.h<d2.h);//注意这里排序是避免相同的宽度被包含
}
int main()
{
	int T,i,mxlen,j,n,r,l,mid;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		scanf("%d%d",&d[i].w,&d[i].h);
		sort(d,d+n,cmp);
		memset(dp,0,sizeof(dp));
		mxlen=0;
		for(i=0;i<n;i++)
	     {   l=0;
	     	r=mxlen;
	     	while(l<r)//利用二分法进行排序找到适合d[i].h的插入的位置
	     	{
	     		mid=(l+r)/2;
	     		if(dp[mid]<=d[i].h)
	     		 l=mid+1;
	     		 else
	     		 r=mid;
	     	}
	     	dp[l]=d[i].h;//在l位置上插入d[i].h
	     	if(l==mxlen)//如果找到的位置刚好在当前序列的尾端则插入
	     	mxlen++;
	     }
		printf("%d\n",mxlen);
   }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值