HDU 2717 Catch That Cow (BFS)

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11784    Accepted Submission(s): 3676


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
  
  
5 17

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

Recommend
teddy   |   We have carefully selected several similar problems for you:  1429 1401 2579 1195 2605 

题解:  给你两个数n, k,规定有3个步骤,1: n+1 , 2: n-1 , 3: n*2......
            要你每分钟只执行其中一步:要求n变成k至少要几分钟,即最少的步骤数。
            简单的bfs。。。。

AC代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int MAX=100000+10;
int vis[MAX*2];   //不乘 2 就会 RE 。。。
int time[MAX*2];
int n,k;

void bfs(int a)
{
	int next;
	int start;
	queue<int>q;
	vis[a]=1;
	time[a]=0;
	
	q.push(a); //将根节点 a 入队 
	while(!q.empty())
	{
		start=q.front(); //取队首元素 
		q.pop();
		for(int i=0;i<3;i++)
		{
			if(i==0)
			{
				next=start+1;
			}
			else if(i==1)  // 写成if。。。智障了 
			{
				next=start-1;
			}
			else 
			{
				next=start*2; 
			}
			if(!vis[next] && next <=MAX && next >= 0) //如果没有访问过,且没有越界,入队,time+1 
			{
				vis[next] = 1;
				q.push(next);
				time[next] = time[start] + 1; 
			}
            if(next==k)
            {
            	printf("%d\n",time[next]);
            	return ;
			}
		}
	}
}

int main()
{
	
	while(~scanf("%d %d",&n,&k))
	{
		memset(vis,0,sizeof(vis));
		memset(time,0,sizeof(time));
		if(n==k)puts("0");
		else bfs(n);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值