PAT甲级1057. Stack (30)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:
Push key
Pop
PeekMedian
where key is a positive integer no more than 105.
Output Specification:
For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print “Invalid” instead.
Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop
Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

树状数组.
sort排序只能做对第一个和最后一个测试点,其他的都超时。
http://www.educity.cn/develop/476845.html
https://www.lyeec.me/binary-index-tree/

#include <cstdio>
using namespace std;
#include <stack>

const int MAX=100000+10;
int c[MAX]={0};

int Lowbit(int t){
    return t&(-t);
}

int Sum(int end){
    int sum=0;
    while(end>0){
        sum+=c[end];
        end-=Lowbit(end);
    }
    return sum;
}

void Update(int pos,int num){
    while(pos<MAX){
        c[pos]+=num;
        pos+=Lowbit(pos);
    }
}

void PeekMedian(int index){
    int left=1,right=MAX-1;
    while(left<right){
        int mid=(left+right)/2;
        if(Sum(mid)>=index) right=mid;
        else left=mid+1;
    }
    printf("%d\n",left);
}

int main(){
    int N;
    scanf("%d",&N);

    stack<int> S;

    for(int i=0;i<N;i++){
        char command[11];
        scanf("%s",command);
        if(command[1]=='o') {
            if(S.empty()) printf("Invalid\n");
            else {
                Update(S.top(),-1);
                printf("%d\n",S.top());
                S.pop();
            }
        }
        else if(command[1]=='u'){
            int Key;
            scanf("%d",&Key);
            S.push(Key);
            Update(Key,1);
        }
        else{
            int n=S.size();
            if(n==0) {
                printf("Invalid\n");
                continue;
            }
            int cnt=(n%2==0)?(n/2):((n+1)/2);
            PeekMedian(cnt);
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值