HDU2923:Einbahnstrasse(Floyd)

Problem Description
Einbahnstra    e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.
 

Input
Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:


A -v -> B
A <-v - B
A <-v -> B


A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.  

 

Output
For each test case, print the total distance traveled using the following format:


k . V


Where k is test case number (starting at 1,) is a space, and V is the result.
 

Sample Input
  
  
4 2 5 NewTroy Midvale Metrodale NewTroy <-20-> Midvale Midvale --50-> Bakerline NewTroy <-5-- Bakerline Metrodale <-30-> NewTroy Metrodale --5-> Bakerline 0 0 0
 

Sample Output
  
  
1. 80


 

题意:一开始给出三个数字,n,c,m,代表城市数,破车数,道路数

然后跟着m条路线,箭头为指向,数字为花费,然后求出从公司派出车,到每个城市回收破车的最小花费,要注意每辆车只能回收一辆破车

 

思路:用floyd最方便了- -

 

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <map>
#include <algorithm>
using namespace std;
#define inf 999999999
const int L = 1005;
int n,c,m;
int a[105][105];
char str[1005][100];
int cnt;
map<string,int> mat;


void Floyd()
{
    int i,j,k;
    for(i = 1; i<=n; i++)
        for(j = 1; j<=n; j++)
            for(k = 1; k<=n; k++)
                if(a[j][i]+a[i][k]<a[j][k])
                    a[j][k] = a[j][i]+a[i][k];
}

int main()
{
    int i,j,val,x,y,len,cas = 1,sum,start;
    char s1[100],s2[100],s3[100];
    char from,to;
    while(~scanf("%d%d%d",&n,&c,&m)&&(n+c+m))
    {
        sum = 0;
        mat.clear();
        for(i = 0; i<=n; i++)
            for(j = 0; j<=n; j++)
                a[i][j] = inf;
        for(i = 0; i<=c; i++)
            scanf("%s",str[i]);
        cnt = 1;
        for(i = 0; i<m; i++)
        {
            scanf("%s %c-%d-%c %s",s1,&from,&val,&to,s3);
            if(!mat[s1])
                mat[s1] = cnt++;
            if(!mat[s3])
                mat[s3] = cnt++;
            x = mat[s1],y = mat[s3];
            if(from == '<' && val<a[y][x])
                a[y][x] = val;
            if(to == '>' && val<a[x][y])
                a[x][y] = val;
        }
        Floyd();
        start = mat[str[0]];
        for(i = 1; i<=c; i++)
            sum+=a[start][mat[str[i]]]+a[mat[str[i]]][start];
        printf("%d. %d\n",cas++,sum);
    }

    return 0;
}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值