poj 3070 矩阵快速幂



链接:戳这里


Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is



Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1
Sample Output

0
34
626
6875
Hint


As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

思路:裸地矩阵快速幂

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include <ctime>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<iomanip>
#include<cmath>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
#define maxn 0x3f3f3f3f
#define MAX 1000100
///#pragma comment(linker, "/STACK:102400000,102400000")
typedef long long ll;
typedef unsigned long long ull;
#define INF (1ll<<60)-1
using namespace std;
const ll mod=10000;
ll n;
struct Matrix{
    ll ma[2][2];
    Matrix(){
        for(int i=0;i<2;i++)
            for(int j=0;j<2;j++)
                ma[i][j]=0;
    }
};
Matrix Mult(Matrix a,Matrix b){
    Matrix c;
    for(int i=0;i<2;i++){
        for(int j=0;j<2;j++){
            for(int k=0;k<2;k++){
                c.ma[i][j]=(c.ma[i][j]+a.ma[i][k]*b.ma[k][j]%mod)%mod;
            }
        }
    }
    return c;
}
Matrix MPow(Matrix a,ll b){
    Matrix tmp;
    for(int i=0;i<2;i++) tmp.ma[i][i]=1;
    while(b){
        if(b%2) tmp=Mult(tmp,a);
        a=Mult(a,a);
        b/=2;
    }
    return tmp;
}
int main(){
    while(scanf("%I64d",&n)!=EOF){
        if(n==-1) break;
        if(n==0){
            cout<<0<<endl;
            continue;
        }
        Matrix a,b;
        a.ma[0][0]=1;a.ma[0][1]=1;a.ma[1][0]=1;
        b=MPow(a,n);
        printf("%I64d\n",b.ma[1][0]%mod);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值