湖南省第十二届大学生计算机程序设计竞赛 A 2016



链接:戳这里


1803: 2016
Time Limit: 5 Sec  Memory Limit: 128 MB
[Submit][Status][Web Board]
Description

 给出正整数 n 和 m,统计满足以下条件的正整数对 (a,b) 的数量:
1. 1≤a≤n,1≤b≤m;
2. a×b 是 2016 的倍数。
Input

输入包含不超过 30 组数据。
每组数据包含两个整数 n,m (1≤n,m≤109).
Output
对于每组数据,输出一个整数表示满足条件的数量。
Sample Input
32 63
2016 2016
1000000000 1000000000
Sample Output
1
30576
7523146895502644
HINT
Source
湖南省第十二届大学生计算机程序设计竞赛


思路:

a*b%2016=0 -> a%2016 * b%2016 =0 -> ((a%2016)*(b%2016))%2016=0


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include <ctime>
#include<queue>
#include<set>
#include<map>
#include<list>
#include<stack>
#include<iomanip>
#include<cmath>
#include<bitset>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
///#pragma comment(linker, "/STACK:102400000,102400000")
typedef long long ll;
typedef long double ld;
#define INF (1ll<<60)-1
#define Max 1e9
using namespace std;
ll n,m;
int num1[2020],num2[2020];
int main(){
    while(scanf("%I64d%I64d",&n,&m)!=EOF){
        for(int i=0;i<=2015;i++) num1[i]=n/2016,num2[i]=m/2016;
        for(int i=1;i<=2015;i++){
            if(i<=n%2016) num1[i]++;
            if(i<=m%2016) num2[i]++;
        }
        ll ans=0;
        for(int i=0;i<=2015;i++){
            for(int j=0;j<=2015;j++){
                if(i*j%2016==0){
                    ans+=1LL*num1[i]*num2[j];
                }
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值