2016 Multi-University Training Contest 1 1002 hdu 5724 博弈



链接:戳这里


Chess
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Problem Description
Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.
 
Input
Multiple test cases.

The first line contains an integer T(T≤100), indicates the number of test cases.

For each test case, the first line contains a single integer n(n≤1000), the number of lines of chessboard.

Then n lines, the first integer of ith line is m(m≤20), indicates the number of chesses on the ith line of the chessboard. Then m integers pj(1≤pj≤20) followed, the position of each chess.
 
Output
For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.
 
Sample Input
2
1
2 19 20
2
1 19
1 18
 
Sample Output
NO
YES
 


思路:

对于每个一行放任意格子,都可以看成二进制上的1,最大也就是(1<<20),预处理出所有的(1~1<<20)的sg函数

则所有放棋子的状态的sg函数都知道了,接下来就是简单的尼姆博弈。抑或和就可以了


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include <ctime>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<iomanip>
#include<cmath>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
#define maxn 0x3f3f3f3f
#define MAX 1000100
#pragma comment(linker, "/STACK:102400000,102400000")
typedef long long ll;
typedef unsigned long long ull;
#define INF (1ll<<60)-1
using namespace std;
int n,m;
int a[1010];
int f[1060100];
int d[33];
int get(int x){
    for(int i=0;i<=20;i++)
        if((1<<i)-1==x) return 0;
    mst(d,0);
    int flag=0,w;
    for(int i=0;i<=20;i++){
        if((1<<i)>x) break;
        else if((x&(1<<i))==0){
            flag=1;
            w=i;
        } else if(flag){
            d[f[x-(1<<i)+(1<<w)]]=1;
        }
    }
    for(int i=0;i<=20;i++){
        if(!d[i]) return i;
    }
}
int main(){
    f[0]=0;
    for(int i=1;i<=(1<<20);i++) f[i]=get(i);
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        int ans=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&m);
            int sum=0;
            for(int j=1;j<=m;j++){
                int x;
                scanf("%d",&x);
                sum+=(1<<(20-x));
            }
            ans^=f[sum];
        }
        if(ans==0) printf("NO\n");
        else printf("YES\n");

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值