hdu 5900 区间dp



链接:戳这里


QSC and Master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Problem Description
Every school has some legends, Northeastern University is the same.

Enter from the north gate of Northeastern University,You are facing the main building of Northeastern University.Ninety-nine percent of the students have not been there,It is said that there is a monster in it.

QSCI am a curious NEU_ACMer,This is the story he told us.

It’s a certain period,QSCI am in a dark night, secretly sneaked into the East Building,hope to see the master.After a serious search,He finally saw the little master in a dark corner. The master said:

“You and I, we're interfacing.please solve my little puzzle!

There are N pairs of numbers,Each pair consists of a key and a value,Now you need to move out some of the pairs to get the score.You can move out two continuous pairs,if and only if their keys are non coprime(their gcd is not one).The final score you get is the sum of all pair’s value which be moved out. May I ask how many points you can get the most?

The answer you give is directly related to your final exam results~The young man~”

QSC is very sad when he told the story,He failed his linear algebra that year because he didn't work out the puzzle.

Could you solve this puzzle?

(Data range:1<=N<=300
1<=Ai.key<=1,000,000,000
0<Ai.value<=1,000,000,000)
 
Input
First line contains a integer T,means there are T(1≤T≤10) test case。

  Each test case start with one integer N . Next line contains N integers,means Ai.key.Next line contains N integers,means Ai.value.
 
Output
For each test case,output the max score you could get in a line.
 
Sample Input
3
3
1 2 3
1 1 1
3
1 2 4
1 1 1
4
1 3 4 3
1 1 1 1
 
Sample Output
0
2
0
 

题意:

给出n对数keyi,vali表示当前这对数的键值和权值,可以操作将连续的两个数合并,如果满足gcd(a[i],a[i+1])>1,得到

的价值是两个数的权值和,每次合并两个数之后,这两个数就会消失,然后旁边的数会接上

比如1 2 3 4 合并了 2 3 则 剩下1 4也可以合并


思路:

1:处理出任意区间内的所有数是否可以合并

对于当前的[l,r]区间,如果区间[l+1,r-1]可以合并,且gcd(a[l]+a[r])>1的话,则整个区间[l,r]可以合并,价值也就是前缀和

同理处理出其他的情况  [l,r-2] [l+1,r]

2:区间dp,对于当前的l,r区间,如果可以合并,则直接加上区间和

反之,则枚举一个中间值k,找出区间内最大满足情况的值


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include <ctime>
#include<queue>
#include<set>
#include<map>
#include<list>
#include<stack>
#include<iomanip>
#include<cmath>
#include<bitset>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
///#pragma comment(linker, "/STACK:102400000,102400000")
typedef long long ll;
typedef long double ld;
#define INF (1ll<<60)-1
#define Max 1e9
using namespace std;
int n;
ll a[330],v[330];
ll g[330][330];
ll gcd(ll a,ll b){
    return b==0?a:gcd(b,a%b);
}
ll sum[330];
ll dp[330][330];
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        mst(g,0);mst(dp,0);sum[0]=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%I64d",&a[i]);
        for(int i=1;i<=n;i++) {
            scanf("%I64d",&v[i]);
            sum[i]=sum[i-1]+v[i];
        }
        for(int i=1;i<=n;i++){
            if(gcd(a[i],a[i-1])>1) g[i][i-1]=1;
        }
        for(int len=2;len<=n;len+=2){
            for(int j=1;j+len-1<=n;j++){
                int l=j,r=j+len-1;
                if(gcd(a[l],a[r])>1 && g[l+1][r-1]) g[l][r]=1;
                if(gcd(a[l],a[l+1])>1 && g[l+2][r]) g[l][r]=1;
                if(gcd(a[r-1],a[r])>1 && g[l][r-2]) g[l][r]=1;
            }
        }
        for(int len=2;len<=n;len++){
            for(int j=1;j<=n-len+1;j++){
                int l=j,r=j+len-1;
                if(g[l][r]) dp[l][r]=sum[r]-sum[l-1];
                else {
                    for(int k=l;k<r;k++)
                        dp[l][r]=max(dp[l][r],dp[l][k]+dp[k+1][r]);
                }
            }
        }
        printf("%I64d\n",dp[1][n]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值