B - Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

此题是深度优先搜索题目:

首先是在一个绕成环的节点中填数,填1---n,并且相邻两个数的和是素数,输出的时候第一个节点中的数总是1,输出各种满足条件的状况,节点当时用数组实现,放一个数就相当于存下一个数,每次dfs总是从2开始,即第一个节点中的数总是为1,并且还要标记1已经走过,在dfs中,需要来一个循环,作用是判断相邻两个数的和是不是素数,如果在判断中看到有一组不是素数,即return,相当于返回到上一层中(此路不通,请走别处),但是这个循环中没有判断第一个和最后一个节点的和是不是素数,所以当步数达到n+1时,需要在里面单独判断,若此时也满足条件,即输出即可,注意:此题中有一个坑,即每组实例之后都要有一个空行。下面看我的代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int n;
int kong[21];
int book[21];
int ans;
int prime(int a)
{
    for(int i=2;i<=sqrt(a);i++)
    {
        if(a%i==0)
            return 1;
    }
    return 0;
}
void dfs(int step)
{
    if(step>=3)
    {
        if(prime(kong[step-1]+kong[step-2]))
            return;
    }
    if(step==n+1)
    {
        if(!prime(kong[1]+kong[n]))
        {
            printf("%d",kong[1]);
            for(int i=2;i<=n;i++)
                printf(" %d",kong[i]);
                printf("\n");
        }
        return;
    }
    for(int i=1;i<=n;i++)
    {
        if(book[i]==0)
        {
            book[i]=1;
            kong[step]=i;
            dfs(step+1);
            book[i]=0;
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(book,0,sizeof(book));
        book[1]=1;
        kong[1]=1;
        printf("Case %d:\n",++ans);
        dfs(2);
        printf("\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值