1069. The Black Hole of Numbers (20)


For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000

题意:

给定一个四位的数字,写出该数字的黑洞过程


分析:

要求四位数字,注意在将数拆成各位的时候,注意不是求所有的为,因为有的数开始是0,所以只要四位,不然第二个,第三个测试点过不了







#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <set>
#include <map>
using namespace std;
int Min(int *d)
{
	int sum = 0;
	for(int i = 0;i < 4;i++)
		sum = sum*10+d[i];
	return sum;
}
int Max(int *d)
{
	int sum = 0;
	for(int i = 3;i >= 0;i--)
	   sum = sum*10+d[i];
	return sum;
}
int main()
{
    int n;
    cin >> n;
    while(1)
    {
    	int d[4];
    	int g = 0;
    	for(int i = 0;i < 4;i++)
    	{
    		d[g++] = n%10;
    		n/=10;
    	}
       sort(d,d+4);
       int maxn = Max(d);
       int minn = Min(d);
       int mul = maxn - minn;
       printf("%04d - %04d = %04d\n",maxn,minn,mul);
       if(mul == 0||mul == 6174)
       	break;
       n = mul;
    }
	return 0;
}





下面给出大神的超级短的代码:







#include <iostream>
#include <algorithm>
using namespace std;
bool cmp(char a, char b) {return a > b;}
int main() {
    string s;
    cin >> s;
    s.insert(0, 4 - s.length(), '0');
    do {
        string a = s, b = s;
        sort(a.begin(), a.end(), cmp);
        sort(b.begin(), b.end());
        int result = stoi(a) - stoi(b);
        s = to_string(result);
        s.insert(0, 4 - s.length(), '0');
        cout << a << " - " << b << " = " << s << endl;
    } while (s != "6174" && s != "0000");
    return 0;
}











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值