PAT 1069. The Black Hole of Numbers (20)(数字黑洞)

官网

1069. The Black Hole of Numbers (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation “N - N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000

解题思路

  • 1.把输入数字的每个位上的数字都提取出来,然后排序再相减,看结果是否为0或者为6174,如果都不是则继续循环。
  • 2.注意输入为1,11,111这种情况。

AC代码

#include<iostream>
#include<string>
#include<vector>
#include<math.h>
#include<algorithm>
#include<cstdio>
using namespace std;
int main(int argc, char *argv[])
{
    int a,b = 0,c = 0;
    cin >> a;
    if (a == 0) {
        printf("0000 - 0000 = 0000\n");
        return 0;
    }
    do {
        b = 0,c = 0;
        vector<int> keep;
        while (a>0) {
            keep.push_back(a%10);
            a = a / 10;
        }
        //排序求最大值
        sort(keep.begin(),keep.end(),greater<int>());
        int len = keep.size();
        while (len<4) {
            keep.push_back(0);
            len++;
        }
        for (int i = 0; i < len; ++i) {
            b += keep[i] * pow(10,len - i - 1);
        }
        //排序求最小值
        sort(keep.begin(),keep.end(),less<int>());
        len = keep.size();
        while (len<4) {
            keep.push_back(0);
            len++;
        }
        for (int i = 0; i < len; ++i) {
            c += keep[i] * pow(10,len - i - 1);
        }
        a = b - c;
        printf("%04d - %04d = %04d\n",b,c,a);
    } while (a!=6174 && a != 0);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值