PAT A1064 2019.08.24 【固定结构BST建树 层序遍历】

1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then Ndistinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

思路分析

这题和1099有点像

也是给定了BST树的结构

这里我直接复用了1099的代码

先把结构建好,输入序列排好序,然后build 之后level

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>
#define MAX 10000
using namespace std;

typedef struct NODE{
	int data;
	struct NODE *left;
	struct NODE *right;
}NODE;

NODE *node[MAX];
int n;
vector<int> data;

int find(NODE *root)
{
	if(root==NULL)return 0;
	if(root->left!=NULL&&root->right!=NULL)
	  return find(root->left)+find(root->right)+1;
	if(root->left!=NULL&&root->right==NULL)
	  return find(root->left)+1;
    if(root->left==NULL&&root->right!=NULL)
	  return find(root->right)+1;
    if(root->left==NULL&&root->right==NULL)
	  return 1;
}

void build(NODE *&root,int begin,int end)
{
	int leftNum = find(root->left);
	root->data = data[begin+leftNum];
	if(begin==end)root->data=data[begin]; 
	if(root->left!=NULL)build(root->left,begin,begin+leftNum-1);
	if(root->right!=NULL)build(root->right,begin+leftNum+1,end);
}

void level(NODE *root)
{
	int time=0;
	NODE *que[MAX];
	int front=-1,rear=-1;
	que[++rear]=root;
	while(front!=rear)
	{
		NODE *node = que[++front];
		if(time==n-1)cout<<node->data;
		else
		{
			cout<<node->data<<" ";
	    	time++;	
		}
		if(node->left!=NULL)que[++rear]=node->left;
		if(node->right!=NULL)que[++rear]=node->right;
	}
	
}

int main()
{

	cin>>n;
	data.reserve(n);
	for(int i=0;i<n;i++)cin>>data[i];
	
	for(int i=0;i<n;i++)
	for(int j=i+1;j<n;j++)
		if(data[j]<data[i])swap(data[j],data[i]);
		
//	for(int i=0;i<n;i++)cout<<data[i]<<" ";
	
	for(int i=0;i<MAX;i++)
	{
		node[i]=new NODE;
		node[i]->left=NULL;
		node[i]->right=NULL;
	}
	
	for(int i=1;i<=n;i++)
	{
		if(2*i<=n)node[i]->left=node[2*i];
		else node[i]->left=NULL;
		if(2*i+1<=n)node[i]->right=node[2*i+1];
		else node[i]->right=NULL;
	}
	NODE *root=node[1];
	
	build(root,0,n-1);
	level(root);
	
	
	
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值