PAT A1125 2019.08.28 【vector sort】

1125 Chain the Ropes (25 分)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

思路分析

刚开始看题目可能有点难理解,但是只要能把样例推导出来,就没问题

注意不要超时(对于已经排好序的序列   average(1st+2nd) <  3th )

#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int n;
vector<int>arr;

int main()
{
	cin>>n;
	for(int i=0;i<n;i++)
	{
		int data;cin>>data;
		arr.push_back(data);
	} 
	sort(arr.begin(),arr.end());
	
//	for(int i=0;i<arr.size();i++)
//	  cout<<arr[i]<<" ";
//	cout<<endl<<endl;
//	
	int data=arr[0];
	for(int i=1;i<n;i++)
	{
		data = (data+arr[i])/2; 
		
//		因为初始序列已经是从小到大排好序了
//		所以不必进行插入,再排序了 ,下面的代码会超时 
//		data=(arr[1]+arr[0])/2;
//		arr.erase(arr.begin(),arr.begin()+2);
//		arr.push_back(data);
//		sort(arr.begin(),arr.end());
		
//		测试输出 
//		for(int i=0;i<arr.size();i++)
//	    cout<<arr[i]<<" ";
//	    cout<<endl<<endl;
	}
	cout<<data;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值