PAT A1143 2019.09.02 【公共祖先 BST性质】

本文探讨了在二叉搜索树(BST)中寻找两个给定节点的最低公共祖先(LCA)的问题。通过预处理BST的前序遍历序列,提出了一种高效算法,能够直接在数组中进行操作,避免了构建树的复杂过程。该算法利用BST的性质来判断每个节点与目标节点的关系,进而找到LCA。同时,文章提供了完整的C++实现代码,并附带样例输入输出,便于理解和验证。
摘要由CSDN通过智能技术生成

1143 Lowest Common Ancestor (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

思路分析

对BST的结点进行遍历,直接遍历数组即可,不用建树

判断BST每个结点与输入两元素U、V的关系(利用BST性质)即可判断此节点是否为U、V的祖先A

如果U V中某个和A相等 则U是V的祖先 || V是U的祖先,否则 LCA of U V is A

ERROR的判断用map,很简单

#include<cstdio>
#include<iostream>
#include<map>
#include<vector>
#define MAX 10010
using namespace std;

int pre[MAX];
map<int,bool>mp;

int main()
{
	int n,m;cin>>m>>n;
	for(int i=0;i<n;i++)
	{
		cin>>pre[i];
		mp[pre[i]]=true;
	}
	
	for(int i=0;i<m;i++)
	{
		int u,v;
		int a;//ancestor
		cin>>u>>v;
		for(int j=0;j<n;j++)
		{
			a=pre[j];
			if(a>=u&&a<=v||a<=u&&a>=v)break;
		}
		
		if(mp[u]==false&&mp[v]==false)
		  printf("ERROR: %d and %d are not found.\n",u,v); 
		else if(mp[u]==false||mp[v]==false)
		  printf("ERROR: %d is not found.\n",mp[u]==false?u:v);
		else if(a==u||a==v)
		{
			if(a==u)printf("%d is an ancestor of %d.\n",u,v);
			else if(a==v)printf("%d is an ancestor of %d.\n",v,u);
		}
		else printf("LCA of %d and %d is %d.\n",u,v,a);
		  
	}
	
	
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值