1003 Emergency (25 分)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
思路分析
在dijkstra的基础上进行 优化 点权,同时计数最短路径条数
#include<cstdio>
#include<iostream>
#include<algorithm>
#define MAX 1000
#define INF 1000000000
using namespace std;
int adt[MAX][MAX];
int vis[MAX]={false};
int dis[MAX];
int pre[MAX];
int wei[MAX];
int n,m,c1,c2;
int num[MAX];//num[i]表示从起点 s 到 i结点 的最短路径条数
int maxWei[MAX];//maxWe[i]表示从起点 s 到 i结点 的最大收集物资量
void dijkstra(int s)
{
dis[s]=0;
num[s]=1;
maxWei[s]=wei[s];
for(int i=0;i<n;i++)
{
int u=-1;
int min=INF;
for(int j=0;j<n;j++)
{
if(vis[j]==false&&dis[j]<min)
{
u=j;
min=dis[j];
}
}
if(u==-1)return;
vis[u]=true;
for(int v=0;v<n;v++)
{
//注意此处为 邻接可达 adt[u][v]!=INF
if(vis[v]==false&&adt[u][v]!=INF)
{
if(dis[u]+adt[u][v]<dis[v])
{
dis[v]=dis[u]+adt[u][v];
pre[v]=u;
num[v]=num[u];
maxWei[v]=maxWei[u]+wei[v];
}
//注意此处的 else if
else if(dis[u]+adt[u][v]==dis[v])
{
num[v]=num[v]+num[u];
if(maxWei[u]+wei[v]>maxWei[v])
maxWei[v]=maxWei[u]+wei[v];
}
}
}
}
}
void dfs(int s,int v)
{
if(v==s)
{
cout<<s<<" ";
return;
}
dfs(s,pre[v]);
cout<<v<<" ";
}
int main()
{
cin>>n>>m>>c1>>c2;
for(int i=0;i<n;i++)cin>>wei[i];
fill(adt[0],adt[0]+MAX*MAX,INF);
fill(dis,dis+MAX,INF);
for(int i=0;i<m;i++)
{
int a,b,c;cin>>a>>b>>c;
adt[a][b]=c;
}
dijkstra(c1);
// for(int i=0;i<n;i++)
// cout<<dis[i]<<" ";
// cout<<endl;
cout<<num[c2]<<" "<<maxWei[c2];
}