PAT A1062 2019.07.15 【sort】

1062 Talent and Virtue (25 分)

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤10​5​​), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

思路分析

对输入的相关性数据进行排序。此题我做了4h,自己写了排序函数,不管是时间复杂度还是空间复杂度都很大,

最后对了3个点,2个超时,1个错误。

然后晴神的代码很简洁,用了algorithm的sort函数,推荐熟练掌握sort函数,考试的时候真要自己来写排序函数,真的要命!

#include<cstdio>
#include<iostream>
#include<algorithm> 
#define MAX 100010
using namespace std;

typedef struct {
	long long int id;
	int virtue;
	int talent;
	int devide;//分类 sage-1 nobleman-2 foolman-3 smallman-4 否则 null-0 
	int total;//总分 
}PERSON;
PERSON person[MAX];

bool cmp(PERSON a,PERSON b)
{
	if(a.devide!=b.devide)return a.devide<b.devide;
	else if(a.total!=b.total)return a.total>b.total;
	else if(a.virtue!=b.virtue)return a.virtue>b.virtue;
	else return a.id<b.id;
}

int main()
{
	int totalNum=0;
	int L=0;
	int H=0;
	scanf("%d %d %d",&totalNum,&L,&H);
	int printLineNum=0;//输出的行数 
	//输入部分 
	for(int i=0;i<totalNum;i++)
	{
		scanf("%lld %d %d",&person[i].id,&person[i].virtue,&person[i].talent);
		person[i].total = person[i].virtue + person[i].talent; 
	    if(person[i].virtue<L || person[i].talent<L) //只要有一项低于最低值 则不输出 
		{
			person[i].devide = 5;continue;
		}
		
		if(person[i].virtue>=H && person[i].talent>=H) //如果都大于最大值 则是 sage 
		{
			printLineNum++;
			person[i].devide = 1;continue;
		}
		
		if(person[i].virtue>=H && person[i].talent<H) //如果前一项大于 后一项小于 则是 noble 
		{
			printLineNum++;
			person[i].devide = 2;continue;
		}
		
		if(person[i].virtue<H && person[i].talent<H &&person[i].virtue>=person[i].talent) //如果都小于 但是有virtue 则是fool 
		{
			printLineNum++;
			person[i].devide = 3;continue;
		}
		printLineNum++;
		person[i].devide = 4;continue;//其余情况都是 small 
		printf("if this show on windows,the program is not correct!");
	}
	
    printf("%d\n",printLineNum);
	sort(person,person+totalNum,cmp);
    for(int i=0;i<printLineNum;i++)
    {
    	printf("%lld %d %d\n",person[i].id,person[i].virtue,person[i].talent);

	}

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值