PAT A1043 2019.07.29 【BST建树】

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

思路分析:

首先要明白BST是什么,这点题目中已经给了定义

首先建立BST与MBST,并求出它们的先序遍历序列,与输入序列相比较

如果相同则输出对应树的后序遍历序列,如果都不相同则输出NO

#include<cstdio>
#include<iostream>
#define MAX 1010 

typedef struct NODE{
	int data;
	struct NODE *left;
	struct NODE *right;
}NODE;
int n;//结点总数 
int input[MAX];//输入序列

int pre[MAX];int preTop=-1;
int preM[MAX];int preMTop=-1;

void insertBST(NODE* &node,int n)
{
	if(node==NULL)//在空结点进行插入操作 
	{
		node = new NODE;
		node->data=n;
		node->left=NULL;
		node->right=NULL;
		return;
	}
	else
	{
	    if(n<node->data)insertBST(node->left,n);
	    if(n>=node->data)insertBST(node->right,n);
	}
} 

void insertMBST(NODE* &node,int n)
{
	if(node==NULL)//在空结点进行插入操作 
	{
		node = new NODE;
		node->data=n;
		node->left=NULL;
		node->right=NULL;
		return;
	}
	else
	{
	    if(n<node->data)insertMBST(node->right,n);
	    if(n>=node->data)insertMBST(node->left,n);
	}
} 


void preorderBST(NODE *root)
{
	if(root==NULL)return;
//	printf("%d ",root->data);
	pre[++preTop]=root->data; 
	preorderBST(root->left);
	preorderBST(root->right);
}

void preorderMBST(NODE *root)
{
	if(root==NULL)return;
//	printf("%d ",root->data);
	preM[++preMTop]=root->data; 
	preorderMBST(root->left);
	preorderMBST(root->right);
}

int outputTemp = 0;
void postorder(NODE *root)//后序遍历只是用来输出 最后结果,与BST 还是MBST无关 
{
	if(root==NULL)return;
	postorder(root->left);
	postorder(root->right);
	printf("%d",root->data);
	outputTemp++;
	if(outputTemp<n)printf(" ");
}

int main()
{
	scanf("%d",&n);
	NODE *BST = NULL;
	NODE *MBST = NULL;
	for(int i=0;i<n;i++)
	{
		int data;
		scanf("%d",&input[i]);
		insertBST(BST,input[i]);
		insertMBST(MBST,input[i]);
	} 
	preorderBST(BST);
	preorderMBST(MBST);
	
	int preflag = 1;
	int preMflag = 1;
	for(int i=0;i<n;i++)
	{
		if(pre[i]!=input[i])preflag = 0;
		if(preM[i]!=input[i])preMflag=0;
	}
	
//	for(int i=0;i<n;i++)printf("%d ",input[i]);printf("\n");
//	for(int i=0;i<n;i++)printf("%d ",pre[i]);printf("\n");
//	for(int i=0;i<n;i++)printf("%d ",preM[i]);printf("\n");
//	printf("%d %d\n",preflag,preMflag);
	
	if(preflag==1)
	{
		printf("YES\n");
		postorder(BST);
		return 0;
	}
	else if(preMflag==1)
	{
		printf("YES\n");
		postorder(MBST);
		return 0;
	}
	else printf("NO");
	
	
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值