PAT A1013 2019.08.07 【DFS BFS 连通分量】

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

思路分析:

此题的本质:求去除了某个结点之后其他图所拥有的连通分量的个数(求图的连通分量)

采用邻接矩阵存储图,使用 BFS、标志位数组 来完成对图的连通分量的计算

最后输出的结果为 (连通分量数-1)  (添加最少的路线)

2019.09.05更新

今天用DFS与BFS做了一下,复习了一下连通分量的求法

下面是新的代码(使用vector建图)

在DFS中visit代表是否访问

在BFS中visit代表是否入队

#include<cstdio>
#include<iostream>
#include<vector> 
#define MAX 1010
using namespace std;

vector<int>adl[MAX];
int n,m,k;
int visit[MAX]={0};

void dfs(int data,int except)
{
	visit[data]=1;
	for(int i=0;i<adl[data].size();i++)
	{
		if(adl[data][i]==except)continue;
		if(visit[adl[data][i]]==0)
		  dfs(adl[data][i],except);
	} 	
}

void bfs(int data,int except)
{
	int que[MAX];
	int front=-1,rear=-1;
	que[++rear]=data;
	visit[data]=1;
	
	while(front!=rear)
	{
		int out=que[++front];
		for(int i=0;i<adl[out].size();i++)
		{
			if(adl[out][i]!=except&&visit[adl[out][i]]==0)
			{
				que[++rear]=adl[out][i];
				visit[adl[out][i]]=1;
			}
		}
	}
}

int traverseGraph(int except)
{
	int num=0;
	for(int i=1;i<=n;i++)
	{
		if(i==except)continue;
		if(visit[i]==0)
		{
//			dfs(i,except);
			bfs(i,except);
			num++;
		}
	}
	return num;
}


int main()
{
	cin>>n>>m>>k;
	for(int i=0;i<m;i++)
	{
		int a,b;cin>>a>>b;
		adl[a].push_back(b);
		adl[b].push_back(a);
	}
	
	for(int i=0;i<k;i++)
	{
		for(int j=0;j<MAX;j++)visit[j]=0;
		
		int except;
		cin>>except;
		cout<<traverseGraph(except)-1<<endl;
	}
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值