1132 Cut Integer (20 分)
Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <231). It is guaranteed that the number of digits of Z is an even number.
Output Specification:
For each case, print a single line Yes
if it is such a number, or No
if not.
Sample Input:
3
167334
2333
12345678
Sample Output:
Yes
No
No
思路分析
切割数字(切割字符串),STL里面现成的string:substr(参数左开右闭) stoi 美滋滋~
此题要要知道 odd(奇数的) even(偶数的)这两个单词
有个易错点,“除”的时候要判断除数是否为0 (这个值6分)
#include<cstdio>
#include<iostream>
#include<string>
using namespace std;
int main()
{
int n;
scanf("%d",&n);
string z,a,b;
for(int i=0;i<n;i++)
{
cin>>z;
// cout<<z.size()<<endl;
a = z.substr(0,z.size()/2);
b = z.substr(z.size()/2,z.size());
long long int zz = stoi(z);
long long int aa = stoi(a);
long long int bb = stoi(b);
// cout<<"a="<<a<<endl;
// cout<<"b="<<b<<endl;
// cout<<"int a = "<<stoi(a)<<endl;
// cout<<"int b = "<<stoi(b)<<endl;
// if(stoi(z) % (stoi(a)*stoi(b)) == 0)cout<<"Yes"<<endl;
// else cout<<"No"<<endl;
if(aa*bb == 0)//判断0--6分
{
printf("No\n");
continue;
}
double out = zz%(aa*bb);
if(out==0)printf("Yes\n");
else printf("No\n");
}
}