PAT A1132 2019.08.18 【string】

本文详细解析了一种算法,该算法能够将一个整数切割成两个较小的整数,并检查原整数是否能被切割后的两个整数的乘积整除。通过使用STL中的string和相关函数,如substr和stoi,实现了一个简洁高效的解决方案。
摘要由CSDN通过智能技术生成

1132 Cut Integer (20 分)

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

思路分析

切割数字(切割字符串),STL里面现成的string:substr(参数左开右闭) stoi 美滋滋~

此题要要知道 odd(奇数的) even(偶数的)这两个单词

有个易错点,“除”的时候要判断除数是否为0 (这个值6分)

#include<cstdio>
#include<iostream>
#include<string>
using namespace std;

int main()
{
	int n;
	scanf("%d",&n);
	string z,a,b;
	
	for(int i=0;i<n;i++)
	{
		cin>>z;
//		cout<<z.size()<<endl;
		a = z.substr(0,z.size()/2);
		b = z.substr(z.size()/2,z.size());
		long long int zz = stoi(z);
		long long int aa = stoi(a);
		long long int bb = stoi(b);
//		cout<<"a="<<a<<endl;
//		cout<<"b="<<b<<endl;
//		cout<<"int a = "<<stoi(a)<<endl;
//		cout<<"int b = "<<stoi(b)<<endl;
//		if(stoi(z) % (stoi(a)*stoi(b)) == 0)cout<<"Yes"<<endl;
//		else cout<<"No"<<endl;

        if(aa*bb == 0)//判断0--6分
        {
        	printf("No\n");
        	continue;
		}

        double out = zz%(aa*bb);
        if(out==0)printf("Yes\n");
        else printf("No\n");
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值