PAT A1128 2019.08.20 【水题】

1128 N Queens Puzzle (20 分)

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q​1​​,Q​2​​,⋯,Q​N​​), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

8q.jpg 9q.jpg
Figure 1 Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q​1​​ Q​2​​ ... Q​N​​", where 4≤N≤1000 and it is guaranteed that 1≤Q​i​​≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

思路分析

皇后问题(不是经典的8皇后问题)

只要判断任意两列的棋子(题中说1列只能有1个棋子)它们的连线的斜率是否为0或±1即可

如果是,则此棋盘配置不符合要求,输出NO 否则输出YES

#include<cstdio>
#include<iostream>
#define MAX 1010
using namespace std;

typedef struct QUEEN{
	double hang;
	double lie;
}QUEEN;
QUEEN q[MAX];

int main()
{
	int k;
	cin>>k;
	for(int ii=0;ii<k;ii++)
	{
		int flag=1;
		double n;
		cin>>n;
		for(int j=1;j<=n;j++)
		{
			double data;
			cin>>data;
			q[j].lie=j;
			q[j].hang=data;
	    }
	    
	    for(int i=1;i<n;i++)//lie
	    {
	    	if(flag==0)break;
	    	for(int j=i+1;j<=n;j++)//lie
	    	{
	    		if(q[i].hang==q[j].hang)flag=0;
	    		if((q[i].hang-q[j].hang)/(q[i].lie-q[j].lie)==1)flag=0;
	    		if((q[i].hang-q[j].hang)/(q[i].lie-q[j].lie)==-1)flag=0;
			}
		}
	    
	    if(flag==1)printf("YES\n");
	    else printf("NO\n");
	}
	
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值