Tunnel Warfare 无脑模拟

 During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately!

Input

  1. The first line of the input contains two positive integers n and m
    (n, m ≤ 50,000) indicating the number of villages and events. Each
    of the next m lines describes an event.

    There are three different events described in different format shown below:

    D x: The x-th village was destroyed.

    Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.

    R: The village destroyed last was rebuilt.
    Output
    Output the answer to each of the Army commanders’ request in order on a separate line.
    Sample Input

    7 9
    D 3
    D 6
    D 5
    Q 4
    Q 5
    R
    Q 4
    R
    Q 4

Sample Output

1
0
2
4

题意: 给你n个桩,m个操作
接下来m行 每行两个数据a b
a=Q时为查询包含b的最大连续子串;
这题是在学长给的线段树练习题中看到的。 看了很久都不会用线段树写,果断无脑暴力模拟一波。

#include <iostream>
#include <set>
#include <functional>
#include<algorithm>
#include<cstdio>
#include<stack>
using namespace std;
set<int > S;
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        int per;
        S.clear();
        S.insert(0);
        S.insert(n+1);
        stack<int> ST;
        for(int i=0;i<m;i++)
        {
            int cao;
            char dos;
            cin>>dos;
            if(dos=='D')
            {
                scanf("%d",&cao);
                ST.push(cao);
                S.insert(cao);
            }
            else if(dos=='Q')
            {
                cin>>cao;
                if(S.find(cao)!=S.end())
                    puts("0");
                else
                {
                    set<int>::iterator it1=S.upper_bound(cao);
                    set<int>::iterator it2=(S.lower_bound(cao));
                    it2--;
                    //cout<<"it1 : it2 "<<*it1<<" "<<*it2<<endl;
                    cout<<(*it1-*it2-1)<<endl;
                }
            }
            else{
                S.erase(ST.top());
                ST.pop();
            }
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值