Sicily 1305 Who’s Winner?

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Nic and Susan play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Nic always starts with p=1, does his multiplication. Then Susan multiplies the number, then Nic and so on. Before a game starts, they draw an integer 1≤n<4,294,967,295 and the winner is who first reaches p≥n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either

Nic wins.

or

Susan wins.

Assume that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Nic wins.
Susan wins.
Nic wins.

Problem Source

ZSUACM Team Member


Solution

这题意有点表述不清,简单来说就是p=1,然后两人先后从2-9中取数字乘上p,Nic先手,谁的操作使得p>=n谁就赢。给出n,问谁赢。

从极限触发列举情况:

n = [1.9]          Nic Win

n = [10,18]     SuSan Win

n = [19,162]   Nic Win

在列举的时候可以知道,Nic有希望的时候就是9*2*9,会取9,而Susan会选2来阻止,同理,当SuSan有希望的时候是2*9*2*9,Nic会取2来阻止。

归纳后模拟就ok啦~


#include <cstdio>

int main()
{
  long long n;

  while (scanf("%lld", &n) == 1)
  {
    long long p = 1;

    while (p)//模拟
    {
      p *= 9;
      if (p >= n)
      {
        printf("Nic wins.\n");
        break;
      }
      p *= 2;
      if (p >= n)
      {
        printf("Susan wins.\n");
        break;
      }
    }
  }

  return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值