Sicily 1077 Cash Machine && POJ 1276

2 篇文章 0 订阅

Constraints

Time Limit: 10 secs, Memory Limit: 32 MB

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of 100 each, 4 bills of 50 each, and 5 bills of 10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Input

The program input is from a text file. Each data set in the file stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <= N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k = 1, N. White spaces can occur freely between the numbers in the input. The input data are correct. For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample InputSample OutputComment
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
735
630
0
0
735=1* 350+3* 125+2* 5
630=6* 100+1* 30 or 21* 30
No cash delivered
No cash delivered

The first data set designates a transaction where the amount of cash requested is 735. The machine contains 3 bill denominations: 4 bills of 125, 6 bills of 5, and 3 bills of 350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is 630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is 0 and, therefore, the machine delivers no cash.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10

Sample Output

735
630
0
0

Solution

题目大意就是给出n中cash的面值和张数,然后给定一个c,问能凑出最接近c的金额数。

这是一个多重背包问题,用二进制拆分后就可以变成01背包问题啦,状态转移方程就是01背包的。


多重背包二进制拆分实现

跟完全背包一样的道理,利用二进制的思想将n[i]件物品i拆分成若干件物品,目的是在0-n[i]中的任何数字都能用这若干件物品代换,另外,超过n[i]件的策略是不允许的。

方法是将物品i分成若干件,其中每一件物品都有一个系数,这件物品的费用和价值都是原来的费用和价值乘以这个系数,使得这些系数分别为1,2,4,…,2^(k-1),n[i]-2^k+1,且k满足n[i]-2^k+1>0的最大整数。例如,n[i]=13,就将该物品拆成系数为1、2、4、6的四件物品。分成的这几件物品的系数和为n[i],表明不可能取多于n[i]件的第i种物品。另外这种方法也能保证对于0..n[i]间的每一个整数,均可以用若干个系数的和表示。


#include <cstdio>
#include <cstring>

int dp[100005], w[1005];

int main()
{
  int n, tot;

  while (scanf("%d%d", &tot, &n) == 2)
  {
    int i, j, d, cash, c = 0;
    memset(dp, 0, sizeof(dp));

    for (i = 0; i < n; ++i)
    {
      scanf("%d%d", &d, &cash);
      for (j = 1; j < d; j <<= 1) //二进制拆分
      {
        w[++c] = j * cash;
        d -= j;
      }
      if (d) w[++c] = d * cash;
    }

    for (i = 1; i <= c; ++i)
    {
      for (j = tot; j >= w[i]; --j)
      {
        if (dp[j] < dp[j-w[i]] + w[i]) dp[j] = dp[j-w[i]] + w[i];
      }
    }

    printf("%d\n", dp[tot]);
  }

  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值