Moving Tables +hdu+贪心

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18769    Accepted Submission(s): 6418


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
  
  
10 20 30
解决方案:1)它有两排房间,可以把他们归回一排;2)对起点进行排序,最左的先移;
代码如下:
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int room1[203];
    int room2[203];

    int temp1[203];
    int temp2[203];
    int T,n,i,j,temp;
    cin>>T;
    while(T)
    {
        cin>>n;
        for(i=0;i<n;i++)
        {
            scanf("%d %d",&room1[i],&room2[i]);
            if(room1[i]%2!=0)
             room1[i]++;///两排换成一排
             if(room2[i]%2!=0)
             room2[i]++;///两排换成一排
             if(room1[i]>room2[i])
             {
                 temp=room1[i];
                 room1[i]=room2[i];
                 room2[i]=temp;
             }///全转成小号房到大号房
        }///统一变成一排,小号房到大号房
        int count=1;


            for(i=0;i<n-1;i++)
         for(j=i+1;j<n;j++)
         {
             if(room1[i]>room1[j])
             {
                 temp=room1[i];
                 room1[i]=room1[j];
                 room1[j]=temp;
                 temp=room2[i];
                 room2[i]=room2[j];
                 room2[j]=temp;

             }
         }///对起点进行排序
         while(1)
          {
           int ok=0;
           int s=0;
             int right=room2[0];
             for(i=1;i<n;i++)
             {
              if(right<room1[i])
              {
                  right=room2[i];

              }
              else
              {
                  temp1[s]=room1[i];
                  temp2[s]=room2[i];
                  s++;
                  ok=1;
              }
             }///模拟移动的过程,一轮结束,记下还没有移动的房间,准备进入下一轮
          n=s;
          for(i=0;i<n;i++)
          {
              room1[i]=temp1[i];
              room2[i]=temp2[i];
          }
          if(ok)
          count++;///记录轮数
          else
          break;///若移动完成,则跳出循环。
          }

        cout<<count*10<<endl;///每轮10分钟,所以乘10
        T--;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值