线段树入门pku2777 涂颜色问题

 
/*
pku 2777
http://poj.org/problem?id=2777
一板子L长,有两个操作
一个着色l到r为c这种颜色,
一个是查询l到r有多少种颜色
就是插入和查询操作
Count Color
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 20838  Accepted: 6034

Description
Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input
First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output
Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source
POJ Monthly--2006.03.26,dodo
*/
#include <iostream>
using namespace std;

const int N= 100010;
const int C= 35;
const int nocolor = -1;
const int mucolor = -2;

struct node
{
    int l,r,c;
};
node tree[N*4];
int color[C];

void create(int k,int l,int r)
{
    tree[k].l = l;
    tree[k].r = r;
    tree[k].c = nocolor;
    if(l == r) return;
    int m = (l+r)>>1;
    create(k+k,l,m);
    create(k+k+1,m+1,r);
}

void insert(int k,int l,int r,int c)
{
    if(tree[k].c==c) return;
    if(l==tree[k].l && r==tree[k].r) {
        tree[k].c = c;
        return;
    }
    // 要传递下去 
    if(mucolor != tree[k].c ) {
        tree[k+k].c = tree[k].c;
        tree[k+k+1].c = tree[k].c;
        tree[k].c = mucolor;
    }
    
    int m = (tree[k].l+tree[k].r)>>1;
    if(r<=m) { insert(k+k,l,r,c); return ;}
    if(l>m) { insert(k+k+1,l,r,c); return;}
    insert(k+k,l,m,c);
    insert(k+k+1,m+1,r,c);
}

void query(int k,int l,int r)
{
    if(tree[k].c == nocolor) return;
    if(tree[k].c != mucolor ) {
        color[tree[k].c] = 1;
        return ;
    }     
    int m = (tree[k].l + tree[k].r) >>1;
    if(r<=m) { query(k+k,l,r); return; }
    if(l>m) { query(k+k+1,l,r); return; }
    query(k+k,l,m);
    query(k+k+1,m+1,r);
}

int main()
{
    int L,T,O;
    int i,l,r,c,t,sum;
    char s[5];
    scanf("%d%d%d",&L,&T,&O);
    
    create(1,1,L);
    tree[1].c = 1;
    while(O--) {
        scanf("%s",s);
        if(s[0]=='C') {
            scanf("%d%d%d",&l,&r,&c);
            if(l<=r) insert(1,l,r,c);
            else insert(1,r,l,c);
        }else {
            scanf("%d%d",&l,&r);            
            for(i=1;i<=T;++i) color[i] = 0;
            sum = 0;
            if(l<=r) query(1,l,r);
            else query(1,r,l);
            
            for(i=1;i<=T;++i) {
                sum+=color[i];
            }
            printf("%d\n",sum);
        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值