杭电第一周电梯问题

问题及代码:

Problem E

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 36   Accepted Submission(s) : 25
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

在我们的城市最高的建筑只有一个电梯。请求列表是由n个正数。数字表示在该楼层电梯将停止,在指定的顺序。电梯向上一层需要6秒,4秒移动到下一层。电梯将停留在每5秒停止。

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

对于一个给定的请求列表,你需要计算花费的总时间履行请求列表。电梯在零楼一开始并没有回到地面时,请求结束。


Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

有多个测试用例。每个案例包含一个正整数N,其次是n个正数。在输入所有的数字都小于100。与N = 0表示输入的结束测试案例。这个测试案例是不能处理。


Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

<pre name="code" class="cpp">#include <iostream>

using namespace std;

int main()
{
    int n;
    while(cin>>n&&n!=0)
    {
        int i,a[n],sum;
        a[0]=0;
        for(i=1;i<=n;i++)
        {
            cin>>a[i];
        }
        sum=0;
        for(i=1;i<=n;i++)
        {
            if(a[i]>a[i-1])
                sum+=6*(a[i]-a[i-1]);
            else
                sum+=4*(a[i-1]-a[i]);
            sum+=5;
        }
        cout<<sum<<endl;
    }
    return 0;
}


 
心得体会:全英文。我也是醉了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值