杭电 1008 Elevator

                                          Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 99851    Accepted Submission(s): 54138


 

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

 

Output
Print the total time on a single line for each test case.
 

 

Sample Input
 
1 2 3 2 3 1 0
 

 

Sample Output
 
17 41
 

 

Author
ZHENG, Jianqiang
 

 

Source
 

 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1005 1002 1009 1021 1003  
 
 
题意概括: 一个电梯,从第0层开始。向上走一层需要6秒,向下走一层需要4秒,每停一层需要5秒。给出所停层数,然后给出每一层的高度,问一共需要多长时间。
 
解题思路:先给出一个循环,将所有的楼层名称写入循环;然后再给出一个循环,判断是向上还是向下,分情况进行计算。
 
代码:
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner input = new Scanner(System.in);
        int value = input.nextInt();
        
        
        while(value != 0){
            int sum = 0;
            if(value != 1){
                int[] array = new int[value + 1];
                array[0] = 0;
                 for(int i = 1; i < array.length; i ++){
                array[i] = input.nextInt();
                 }
                for(int i = 0, j = 1; i < array.length - 1; i ++, j ++){
                if(j < array.length){
                    if(array[j] - array[i] > 0 ){
                        sum += 6 * (array[j] - array[i]);
                    }
                    else{
                        sum += 4 * (array[i]- array[j]);
                    }
                }
            }
                System.out.println(sum + value * 5); 
                value = input.nextInt();
         }
            else{
                int[]  array = new int[1];
                array[0] = input.nextInt();
                System.out.println(array[0] * 6 + 5);
                value = input.nextInt();
            }   
        }
    }   
}

错误反思:

又忘记考虑了只有一层的情况,以后要注意。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值