POJ 1328:Radar Installation 【贪心】

Radar Installation

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 69   Accepted Submission(s) : 35
Problem Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


 

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
 

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
 

Sample Input
  
  
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 1
 

思路:该题题意是为了求出能够覆盖所有岛屿的最小雷达数目,每个小岛对应x轴上的一个区间,在这个区间内的任何一个点放置雷达,则可以覆盖该小岛,区间范围的计算用[x-sqrt(d*d-y*y),x+sqrt(d*d-y*y)];这样,问题即转化为已知一定数量的区间,求最小数量的点,使得每个区间内斗至少存在一个点。每次迭代对于第一个区间,选择最右边一个点, 因为它可以让较多区间得到满足, 如果不选择第一个区间最右一个点(选择前面的点), 那么把它换成最右的点之后,以前得到满足的区间, 现在仍然得到满足, 所以第一个区间的最右一个点为贪婪选择, 选择该点之后, 将得到满足的区间删掉,进行下一步迭代, 直到结束。

AC-code:
<pre name="code" class="cpp">#include<stdio.h>
#include<algorithm>
#include<cmath>
using namespace std;

struct rad
{
	float l,r;
}a[1005];

bool cmp(rad a,rad b)
{
	if(a.r==b.r)
		return a.l>b.l;
	else
		return a.r<b.r;
}
int main()
{
	int n,d,x,y,i,j=0,cont;
	float temp;
	while(scanf("%d%d",&n,&d),n||d)
	{
		int flag=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&x,&y);
			a[i].l=x-sqrt(d*d-y*y);
			a[i].r=x+sqrt(d*d-y*y);
			if(y>d)
				flag=1;
		}
		if(flag)
		{
			j++;
			printf("Case %d: ",j);
			printf("-1\n");
			continue;	
		}
		sort(a,a+i,cmp);
		cont=1;
		temp=a[0].r;
		for(i=1;i<n;i++)
		{
			if(temp<a[i].l)
			{
				cont++;
				temp=a[i].r;
			}
		}
		j++;
		printf("Case %d: ",j);
		printf("%d\n",cont);
	}
	return 0;
}


 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值