POJ 2553:The Bottom of a Graph【强连通】

The Bottom of a Graph

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 2
Problem Description
We will use the following (standard) definitions from graph theory. Let V be a nonempty and finite set, its elements being called vertices (or nodes). Let E be a subset of the Cartesian product V×V, its elements being called edges. Then G=(V,E) is called a directed graph.
Let n be a positive integer, and let p=(e1,...,en) be a sequence of length n of edges ei∈E such that ei=(vi,vi+1) for a sequence of vertices (v1,...,vn+1). Then p is called a path from vertex v1 to vertex vn+1 in G and we say that vn+1 is reachable from v1, writing (v1→vn+1).
Here are some new definitions. A node v in a graph G=(V,E) is called a sink, if for every node w in G that is reachable from v, v is also reachable from w. The bottom of a graph is the subset of all nodes that are sinks, i.e., bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.
 

Input
The input contains several test cases, each of which corresponds to a directed graph G. Each test case starts with an integer number v, denoting the number of vertices of G=(V,E), where the vertices will be identified by the integer numbers in the set V={1,...,v}. You may assume that 1<=v<=5000. That is followed by a non-negative integer e and, thereafter, e pairs of vertex identifiers v1,w1,...,ve,we with the meaning that (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.
 

Output
For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.
 

Sample Input
  
  
3 3 1 3 2 3 3 1 2 1 1 2 0
 

Sample Output
  
  
1 3 2
  • 题目大意      若节点V所能到达的点{w},都能反过来到达v,那我们称v是sink。  
  • 强连通+缩点  
  • 就是求极大连通分量,最后统计出度为0的点,排序后输出初度为0的分量包含的每一个点。
AC——code:
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<stack>
#define min(a,b) a>b?b:a
#define MAXN 5000
using namespace std;
int dfn[MAXN],low[MAXN],sccno[MAXN],instack[MAXN],head[MAXN];
int num,scc_cnt,dfs_clock;
vector<int>scc[MAXN];
stack<int>s;
struct Eage
{
	int from,to,next;
}eage[MAXN*MAXN];
void add(int a,int b)
{
	Eage e={a,b,head[a]};
	eage[num]=e;
	head[a]=num++;
}

void tarjan(int u)
{
	int v;
	low[u]=dfn[u]=++dfs_clock;
	instack[u]=1;
	s.push(u);
	for(int i=head[u];i!=-1;i=eage[i].next)
	{
		v=eage[i].to;
		if(!dfn[v])
		{
			tarjan(v);
			low[u]=min(low[v],low[u]);
		}
		else if(instack[v])
			low[u]=min(dfn[v],low[u]);
	}
	if(low[u]==dfn[u])
	{
		scc_cnt++;
		scc[scc_cnt].clear();
		do
		{
			v=s.top();
			s.pop();
			instack[v]=0;
			sccno[v]=scc_cnt;
			scc[scc_cnt].push_back(v);
		}while(u!=v);
	}
}

int in[MAXN],out[MAXN];

int main()
{
	int n,m,a,b,x,i,j;
	while(scanf("%d%d",&n,&m),n)
	{
		memset(head,-1,sizeof(head));
		num=0;
		while(m--)
		{
			scanf("%d%d",&a,&b);
			add(a,b);
		}
		scc_cnt=dfs_clock=0;
		memset(dfn,0,sizeof(dfn));
		memset(low,0,sizeof(low));
		memset(instack,0,sizeof(instack));
		memset(sccno,0,sizeof(sccno));
		for(i=1;i<=n;i++)
			if(!dfn[i])
				tarjan(i);
		memset(in,0,sizeof(in));
		for(i=1;i<=n;i++)
		{
			for(j=head[i];j!=-1;j=eage[j].next)
				if(sccno[i]!=sccno[eage[j].to])
				{
					in[sccno[i]]=1;
					break;
				}
		}
		int sum=0;
		for(i=1;i<=scc_cnt;i++)
			if(!in[i])
			{
				for(j=1;j<=n;j++)
					if(sccno[j]==i)
						out[sum++]=j;
			}
		sort(out,out+sum);
		if(sum!=0)
		{
			for(i=0;i<sum-1;i++)
				printf("%d ",out[i]);
			printf("%d\n",out[sum-1]);
		}
		else
		{
			printf("\n");
			continue;
		}
	}
	return 0;
}



  • 题目大意      若节点V所能到达的点{w},都能反过来到达v,那我们称v是sink。  
  • 强连通+缩点  
  • 就是求极大连通分量,最后统计出度为0的点,排序后输出初度为0的分量包含的每一个点。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值