POJ 2553:The Bottom of a Graph(强连通Tarjan)

The Bottom of a Graph
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11760 Accepted: 4849

Description

We will use the following (standard) definitions from graph theory. Let  V be a nonempty and finite set, its elements being called vertices (or nodes). Let  E be a subset of the Cartesian product  V×V, its elements being called edges. Then  G=(V,E) is called a directed graph. 
Let  n be a positive integer, and let  p=(e1,...,en) be a sequence of length  n of edges  ei∈E such that  ei=(vi,vi+1) for a sequence of vertices  (v1,...,vn+1). Then  p is called a path from vertex  v1 to vertex  vn+1 in  Gand we say that  vn+1 is reachable from  v1, writing  (v1→vn+1)
Here are some new definitions. A node  v in a graph  G=(V,E) is called a sink, if for every node  w in  G that is reachable from  vv is also reachable from  w. The bottom of a graph is the subset of all nodes that are sinks, i.e.,  bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.

Input

The input contains several test cases, each of which corresponds to a directed graph  G. Each test case starts with an integer number  v, denoting the number of vertices of  G=(V,E), where the vertices will be identified by the integer numbers in the set  V={1,...,v}. You may assume that  1<=v<=5000. That is followed by a non-negative integer  e and, thereafter,  e pairs of vertex identifiers  v1,w1,...,ve,we with the meaning that  (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.

Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.

Sample Input

3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output

1 3
2

Source


题意:给你一堆点,一堆边,找到缩点之后出度为0的节点, 然后将节点编号从小到大排序输出。

思路:Tarjan,缩点染色,判断出度为0的强连通分量,用数组记录后排序输出。

#include<stdio.h>  
#include<string.h>  
#include<algorithm>  
using namespace std;  
#define maxn 1000000  
int ans[maxn], degree[maxn];  
int color[maxn], stack[maxn], vis[maxn], dfn[maxn], low[maxn];  
int n, m, top, cnt, sig, head[maxn];  
struct node{
	int v, next;
}edge[maxn];
void init()  
{  
	memset(head, -1, sizeof(head));
    memset(degree,0,sizeof(degree));  
    memset(color,0,sizeof(color));  
    memset(stack,0,sizeof(stack));  
    memset(low,0,sizeof(low));  
    memset(dfn,0,sizeof(dfn));  
    memset(vis,0,sizeof(vis));  
}  
void Tarjan(int u)  
{  
    vis[u]=1;  
    low[u]=dfn[u]=cnt++;  
    stack[++top]=u;  
    for(int i=head[u];i!=-1;i=edge[i].next)  
    {  
        int v=edge[i].v;  
        if(vis[v]==0)
			Tarjan(v);  
        if(vis[v]==1)
			low[u]=min(low[u], low[v]);  
    }  
    if(dfn[u]==low[u])  
    {  
        sig++;  
        do{  
            color[stack[top]]=sig;  
            vis[stack[top]]=-1;  
        }while(stack[top--]!=u);  
    }  
}  

int main()  
{  
    while(~scanf("%d", &n), n)  
    {   
        scanf("%d", &m);  
        init();  
        for(int i=0;i<m;i++)  
        {  
			int a, b;
			scanf("%d%d", &a, &b);
			edge[i].v=b;
			edge[i].next=head[a];
			head[a]=i;
        }  
        top=0;cnt=1;sig=0;  
		for(int i=1;i<=n;i++)  
		    if(vis[i]==0)  
		        Tarjan(i); 
		for(int i=1;i<=n;i++)  
		    for(int j=head[i];j!=-1;j=edge[j].next)  
		    {  
		        int v=edge[j].v;  
		        if(color[i]!=color[v])  
		            degree[color[i]]++;    
		    }  
		int tot=0;  
		for(int i=1;i<=sig;i++)  
		{  
		    if(degree[i]>0)continue;  
		    for(int j=1;j<=n;j++)  
		        if(color[j]==i)  
		            ans[tot++]=j;
		}  
		sort(ans,ans+tot);  
		for(int i=0;i<tot;i++)  
		{  
		    if(i==0)
				printf("%d",ans[i]);  
		    else 
				printf(" %d",ans[i]);  
		}  
		printf("\n"); 
    }  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hhjian6666

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值