How many prime numbers
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 14709 Accepted Submission(s): 5106
Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.
Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
Output
For each case, print the number of prime numbers you have found out.
Sample Input
3 2 3 4
Sample Output
2
AC-code:
#include<cstdio>
#include<cmath>
int main()
{
int n,ans,a,i,flag;
while(scanf("%d",&n)!=EOF)
{
ans=0;
while(n--)
{
flag=0;
scanf("%d",&a);
int k=sqrt(a);
for(i=2;i<=k;i++)
if(a%i==0)
{
flag=1;
break;
}
if(!flag)
ans++;
}
printf("%d\n",ans);
}
return 0;
}