HDU 5671:Matrix【技巧】

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 620    Accepted Submission(s): 259


Problem Description
There is a matrix  M  that has  n  rows and  m  columns  (1n1000,1m1000) .Then we perform  q(1q100,000)  operations:

1 x y: Swap row x and row y  (1x,yn) ;

2 x y: Swap column x and column y  (1x,ym) ;

3 x y: Add y to all elements in row x  (1xn,1y10,000) ;

4 x y: Add y to all elements in column x  (1xm,1y10,000) ;
 

Input
There are multiple test cases. The first line of input contains an integer  T(1T20)  indicating the number of test cases. For each test case:

The first line contains three integers  n m  and  q .
The following  n  lines describe the matrix M. (1Mi,j10,000)  for all  (1in,1jm) .
The following  q  lines contains three integers  a(1a4) x  and  y .
 

Output
For each test case, output the matrix  M  after all  q  operations.
 

Sample Input
  
  
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
 

Sample Output
  
  
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
思路:直接模拟会超时的,比较好的方法就是用数组存储它们的操作后的位置和加的值;
AC-code:
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
int map[1005][1005],A[1005],B[1005],C[1005],D[1005];
int main()
{
	int T,n,m,q,i,j,x,y;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&n,&m,&q);
		memset(A,0,sizeof(A));
		memset(B,0,sizeof(B));
		memset(C,0,sizeof(C));
		memset(D,0,sizeof(D));
		for(i=1;i<=n;i++)
			A[i]=i;
		for(i=1;i<=m;i++)
			B[i]=i;
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				scanf("%d",&map[i][j]);
		while(q--)
		{
			scanf("%d%d%d",&i,&x,&y);
			if(i==1)
				swap(A[x],A[y]);
			if(i==2)
				swap(B[x],B[y]);
			if(i==3)
				C[A[x]]+=y;
			if(i==4)
				D[B[x]]+=y;
		}
		for(i=1;i<=n;i++)
		{
			printf("%d",map[A[i]][B[1]]+C[A[i]]+D[B[1]]);
			for(j=2;j<=m;j++)
				printf(" %d",map[A[i]][B[j]]+C[A[i]]+D[B[j]]);
			printf("\n");
		}
	}
	return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值