周期串 UVA - 455

原题:

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one repetition of ”abcabcabcabc”). Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line. Sample Input

1
HoHoHo

Sample Output

2

 

大意:

如果一个字符串可以由某个长度为k的字符串重复多次得到,则称该串以k为周期。例如,abcabcabcabc以3为周期(注意,它也以6和12为周期)。

输入一个长度不超过80的字符串,输出其最小周期。

 

分析:

对于每一个字符串,k的可能取值为1-n(n为字符串的长度),其中还可以跳过那些,n%k!=0的情况,比如长度为12的字符串,那么k只可能是1,2,3,4,6,12.

所以我们用一个for循环从1开始找,f 函数即用来判断当前的 i 是不是答案,如果是的话就返回1,然后找啊找啊,如果到最后一个元素的前一个,即n-1,还不是,循环结束,注意此时的 i 会++,即此时 i = n,刚刚好是正确答案(因为前面找遍了,没有找到答案)

然后注意输出格式,多组输出,每组用空行分开,最后一行的行末不要有多余的空行。

下面是AC代码:

#include<iostream>
using namespace std;

int f(int i,string s)
{
	int flag=1;
	int temp=i;
	int j=0;
	while(i<s.length()&&flag)
	{
		for(j=0; j<temp&&i+j<s.length(); j++)
		{
			if(s[j]!=s[j+i])
			{
				flag=0;
				break;
			}
		}
		i+=temp;
	}
	return flag;
}
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		string s;
		cin>>s;
		int i;
		for(i=1; i<s.length(); i++)
		{
			if(s.length()%i)continue;
			if(f(i,s))break;
		}
		if(T)cout<<i<<endl<<endl;
		else cout<<i<<endl;
	}
	return 0;
}

Over.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值