ZOJ-3311 字符串

3311:满足下列情况的字符串AC,否则WA
1. there are only three distinct capital letters of the strings: Z, O, and J;
2. any string that is in the form xZOJxO is acceptable, where x is a string either empty or composed of O's only;
3. if aZbJc is acceptable, then aZbOJcO is acceptable, where a, b and c are all strings either empty or composed of O's only

Sample Input

ZOJO
OZOJOO
OZOOJOOO
OZOZOJOO
OOZOOJO

Sample Output

Accepted
Accepted
Accepted
Wrong Answer
Wrong Answer

思路:字符串拆分,统计前中后三部分个数。
注意Z和J的个数判断以及顺序判断。
一开始没判断顺序WA了好久。%>_<%


#include<iostream>
using namespace std;
#include<string.h>
#include<string>

string str;
int main()
{
bool isAC;
string left;
string top;
string mid;
string end;

while(cin>>str)
{
isAC = true;
if(str.find("Z")!=string::npos)
{
left = str.substr(str.find("Z")+1,str.length());
if(left.find("Z")!=string::npos)
isAC = false;
}
else
isAC=false;

if(str.find("J")!=string::npos)
{
left = str.substr(str.find("J")+1,str.length());
if(left.find("J")!=string::npos)
isAC = false;
}
else
isAC=false;

//J come before Z
if(str.find("J")<str.find("Z"))
isAC=false;

if(isAC)
{
top = str.substr(0,str.find("Z"));
mid = str.substr(str.find("Z")+1,str.find("J")-str.find("Z")-1);
end = str.substr(str.find("J")+1,str.length());
if(!(end.length()-top.length()==mid.length()&&mid.length()>=1))
isAC = false;
}


if(isAC)
cout<<"Accepted"<<endl;
else
cout<<"Wrong Answer"<<endl;
}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值