hdu1358 Period(kmp字符串比较)

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

翻译:找有重复前缀1的前缀2,输出前缀2的长度和前缀2中前缀1重复的次数
例如aabaab
第一组:前缀2是aa, 前缀1是a 输出前缀2的长度2, 前缀1的重复次数2
第一组:前缀2是aabaab, 前缀1是aab 输出前缀2的长度6, 前缀1的重复次数2

#include<cstdio>
#include<cstring>

#define M 1000010
int ne[M], n;
char a[M];

void GetNext()
{
    int i = 0, j = -1;
    ne[0] = -1;
    while (i < n)
    {
        if(j == -1 || a[i] == a[j]){
            ne[++i] = ++j;
        }
        else j = ne[j];//回溯至上一个
    }
}

void print()
{
    int j, i;
    for(i=0; i<=n; i++){
        if(ne[i] == -1 || ne[i] == 0)
            continue;
        j = i - ne[i];
        if(i%j == 0)
            printf("%d %d\n", i, i/j);
    }
    printf("\n");
}

int main()
{
    int i=0;
    while(scanf("%d", &n) != EOF && n != 0)
    {
        scanf("%s", &a);
        i++;
        printf("Test case #%d\n", i);
        GetNext();
        print();
    }
    return 0;
}
/*
思路是先构造出 next[] 数组,下标为 i,定义一个变量 j = i - next[i] 就是next数组下标和下标对应值的差,如果这个差能整除下标 i,即 i%j==0 ,
则说明下标i之前的字符串(周期性字符串长度为 i)一定可以由一个前缀周期性的表示出来,这个前缀的长度为刚才求得的那个差,即 j,则这个前缀出现的次数为 i/j 。
所以最后输出i和i/j即可。
*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值