Period 和 字符串周期

Period

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 16   Accepted Submission(s) : 3
Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.
 

Output
For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 
求出next[]发现:
  前缀为i个字符的串 的 周期=i-next[i]    循环次数=i/周期,   (i % 周期 != 0,不存在周期)。

代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int next[1000005];
char s[1000005];
int n , m ;
void get_next()
{
	int j ;
	next[1]=next[0]= 0;
	for(int i = 1; i < m; i ++)
	{
		j = next[i];
		while(j && s[i] != s[j]) j = next[j];
		next[i + 1] = s[i] == s[j] ? j + 1 : 0;
	}
	printf("Test case #%d\n",n++);
	for(int i = 1; i <= m; i ++)
	{
		if(next[i] > 0 && i % (i - next[i])== 0)
		     printf("%d %d\n",i,i/(i - next[i]));
	}
	printf("\n");
}
int main()
{
	n = 1;
	while(scanf("%d",&m),m)
	{
		scanf("%s",s);
		get_next();
	}
	return 0;
}

与上面的对比:

example:
     如果一个字符串可以由某个长度为k的字符串重复多次得到,我们说这个串以k 为周期。如,abcabcabcabc以3为周期(注意,它也以6,12 为周期)。输人一个长度不超过80的串,输出它的最小周期。


代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
char str[100];
int next[105];
int m ;
void kmp()
{
    int j = 0;
    next[0] = next[1] = 0;
    for(int i = 1; i < m; i ++)
    {
        j = next[i];
        while(j && str[j]!=str[i]) j = next[j];
        next[i+1] = str[j] == str[i] ? j+1:0;
    }
}
int main()
{
    while(cin >> str)
    {
        m  = strlen(str);
        kmp();
        for(int i = 0; i <= m; i ++)
            cout << next[i] << " ";
        cout << endl;
        if(next[m] != 0 && m %(m-next[m]) == 0) printf("%d\n",m-next[m]);
        else
            printf("%d\n",m);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值