hdu 2594 Simpsons’ Hidden Talents(kmp)

 Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2. 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

题解
该题让求字符串1的前缀和字符串2的后缀最长的公共部分
因此我们让串1当模式串,求出他的next【】,由于是求2的后缀与1的前缀的公共,所以直接求2的最后一个字母在1的位置就能得出最长公共部分的长度
注意:由于模式串可能比主串还长,所以在kmp算法中判断条件应该只关心主串,而非模式串

#include<bits/stdc++.h>
using namespace std;

int ne[50050];

void GetNext(char *b){
    int len = strlen(b);
    int i = 0, j = -1;
    ne[0] = -1;
    while(i < len){
        if(j == -1 || b[i] == b[j]){
            if(b[++i] == b[++j])
                ne[i] = ne[j];
            else
                ne[i] = j;
        }
        else j = ne[j];
    }
}

int kmpcompare(char *a, char *b){
    int lena = strlen(a);
    int lenb = strlen(b);
    int i = 0, j = 0;
    while(i < lena){
        if(j == -1 || a[i] == b[j])
            j++, i++;
        else    j = ne[j];
    }
    return j;
}

int main(){
    char a[50050];
    char b[50050];
    while(scanf("%s%s", a, b) != EOF){
        GetNext(a);
        int t = kmpcompare(b, a);
        for(int i=0; i<t; i++){
            putchar(a[i]);
        }
        if(t)
            printf(" ");
        printf("%d\n", t);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值