【笨方法学PAT】1015 Reversible Primes (20 分)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10 

23 2

23 10

-2

Sample Output:

Yes 

Yes

No

二、题目大意

判断一个数是否是质数,同时对这个数进制转换,转换后的数字反转,重新转为10进制,得到的数字是否是质数。

三、考点

进制转换

四、解题思路

1、读取数字,对<0的条件特别处理;

2、进制转换,比较常规;

3、判断是否是质数;

4、输出结果。

五、代码

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

//转换为d进制,反转,之后转化为10进制
int toRadixReverseToTen(int n, int d) {
	int m = 0;
	while (n != 0) {
		int a = n%d;
		n = n / d;
		m = m*d + a;
	}
	return m;
}

//判断素数
bool isPrime(int n) {
	
	//注意,加上这个判断!!
	if (n < 2)
		return false;
	if (n == 2 || n == 3)
		return true;

	//使用i*i代替sqrt,节省计算时间
	for (int i = 2; i * i <=n; ++i) {
		if (n%i == 0)
			return false;
	}
	return true;
}
int main() {
	int n, d;
	while (1) {
		cin >> n;
		if (n < 0) 
			break;
		cin >> d;

		//反转
		int m = toRadixReverseToTen(n, d);

		//判断n和m同时都是素数
		if (isPrime(n)&&isPrime(m))
			cout << "Yes" << endl;
		else
			cout << "No" << endl;
	}
	system("pause");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值