【笨方法学PAT】1084 Broken Keyboard (20 分)

一、题目

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

二、题目大意

现在给出应该输入的一段文字、以及实际被输入的文字,请你列出坏掉的那些键

三、考点

string、map或者hash

四、注意

1、可以直接toupper变成大写;

2、使用map或者hash存储出现的字符;

3、使用set保存坏掉的键,但set会自动排序,需要一边存储,一边输出。

五、代码

#include<iostream>
#include<string>
#include<unordered_map>
#include<set>
using namespace std;
int main() {
	//read
	string s1, s2;
	cin >> s1 >> s2;

	//toupper and build map
	unordered_map<char, int> un_map;
	for (int i = 0; i < s1.length(); i++)
		s1[i] = toupper(s1[i]);
	for (int i = 0; i < s2.length(); i++) {
		s2[i] = toupper(s2[i]);
		un_map[s2[i]] = 1;
	}
	
	//solve and output
	set<char> sset;
	for (int i = 0; i < s1.length(); ++i) {
		if (un_map[s1[i]] == 0) {
			if (sset.find(s1[i]) == sset.end()) {
				sset.insert(s1[i]);
				cout << s1[i];
			}
		}
	}

	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值