【笨方法学PAT】1124 Raffle for Weibo Followers (20 分)

一、题目

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

二、题目大意

从转发的网友中按顺序每隔n个人就发出一个红包,从s开始。不能重复领取,如果当前人已经中奖,递延到下一位。

三、考点

set、逻辑

四、注意

1、使用set维护已经领奖的人的名单;

2、使用int维护当前领奖轮到第几个人了;

3、在遍历的过程中,确定当前iindex的关系即可。

五、代码

#include<iostream>
#include<set>
#include<string>
using namespace std;
int main() {
	//read
	int n;
	cin >> n;

	//solve
	set<int> sset;
	for (int i = 0; i < n; ++i) {
		string s;
		cin >> s;
		int m = 0;
		for (int j = 0; j < s.length(); ++j)
			m += s[j] - '0';
		sset.insert(m);
	}

	//output
	cout << sset.size()<<endl;
	for (auto it = sset.begin(); it != sset.end(); ++it) {
		if (it != sset.begin())
			cout << " ";
		cout << *it;
	}

	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值