【笨方法学PAT】1144 The Missing Number (20 分)

一、题目

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

二、题目大意

给n个数字,找到不在这个数字列表里面的最小的正整数

三、考点

数组

四、注意

1、N有最大限制, N (≤10​5​​);

2、在读取的时候要判断读取的数是否比n大,否则只有18分。

五、代码

#include<iostream>
#define N 100000010
using namespace std;
bool a[N] = { false };
int main() {
	//read
	int n;
	cin >> n;
	for (int i = 0; i < n;++i) {
		int m;
		cin >> m;
		if (m > 0 && m <= n) {
			a[m] = true;
		}
	}

	//solve
	for (int i = 1; i<N; ++i)
		if (a[i] == false) {
			cout << i;
			break;
		}

	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值