【笨方法学PAT】1020 Tree Traversals (25 分)

一、题目

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

二、题目大意

给定后序、中序,求层序遍历

三、考点

二叉树

四、注意

1、根据后序、中序建树;

2、BFS层序遍历;

3、有方法利用遍历的性质,不建树直接获得层序,https://www.liuchuo.net/archives/2100,刚开始觉得很厉害,特别记了下这种方法,结果考场上没有考虑给定的数据,直接套用,GG了,还是建议使用笨方法,结硬寨打呆仗,以不变应万变!

4、也可以形成自己的建树的风格,统一使用指针或者数组,用得更加纯熟。

五、代码

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
vector<int> post, in;
struct node {
	int val;
	node *left, *right;
};
node* buildTree(int pl, int pr, int il, int ir) {
	//return 
	if (pl > pr)
		return NULL;

	//get root
	int i;
	for (i = il; i <= ir; ++i) {
		if (in[i] == post[pr]) {
			break;
		}
	}

	//build tree
	node *root = new node;
	root->val = post[pr];
	root->left = buildTree(pl, pl+(i-1-il), il, i - 1);
	root->right = buildTree(pr-1-(ir-i-1), pr-1, i + 1, ir);

	return root;
}
int main() {
	//read
	int n;
	cin >> n;
	post.resize(n), in.resize(n);
	for (int i = 0; i < n; ++i)
		cin >> post[i];
	for (int i = 0; i < n; ++i)
		cin >> in[i];

	//build tree
	node *root = NULL;
	root = buildTree(0, n - 1, 0, n - 1);

	//bfs
	queue<node*> que;
	que.push(root);
	vector<int> level;
	while (!que.empty()) {
		node *tmp = que.front();
		que.pop();
		level.push_back(tmp->val);
		if(tmp->left!=NULL)
			que.push(tmp->left);
		if(tmp->right!=NULL)
			que.push(tmp->right);
	}

	//output
	for (int i = 0; i < n; ++i) {
		if (i != 0)
			cout << " ";
		cout << level[i];
	}

	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值