【笨方法学PAT】1043 Is It a Binary Search Tree (25 分)

一、题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

二、题目大意

给定一个整数键值序列,现请你编写程序,判断这是否是对一棵二叉搜索树或其镜像进行前序遍历的结果。

三、考点

BST

四、注意

1、有神奇的操作,但笨方法,建树;

2、建树,之后判断前序是否一致,不一致的话,反转BST,继续判断前序是否一致;

3、通过DFS获得后序。

五、代码

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct node {
	int val;
	node *left, *right;
};
vector<int> pre, post;

node* buildTree(node* root, int val) {
	if (root == NULL) {
		root = new node();
		root->val = val;
		root->left = root->right = NULL;
		return root;
	}
	if (val < root->val)
		root->left = buildTree(root->left, val);
	else
		root->right = buildTree(root->right, val);
	return root;
}

void dfs(node* root) {
	if (root == NULL)
		return;
	pre.push_back(root->val);
	if (root->left != NULL)
		dfs(root->left);
	if (root->right != NULL)
		dfs(root->right);
	return;
}

void dfsPost(node* root) {
	if (root == NULL)
		return;
	if (root->left != NULL)
		dfsPost(root->left);
	if (root->right != NULL)
		dfsPost(root->right);
	post.push_back(root->val);
	return;
}

node* invertBST(node* root) {
	if (root==NULL)
		return NULL;
	swap(root->left, root->right);
	if (root->left != NULL)
		root->left = invertBST(root->left);
	if (root->right != NULL)
		root->right = invertBST(root->right);
	return root;
}

int main() {
	//read
	int n;
	cin >> n;
	node* root=NULL;
	vector<int> vec(n);
	for (int i = 0; i < n; ++i) {
		cin >> vec[i];
		root = buildTree(root, vec[i]);
	}

	//judge BST
	dfs(root);
	bool flag = true;
	for (int i = 0; i < n; ++i) {
		if (vec[i] != pre[i]) {
			flag = false;
			break;
		}
	}

	//is BST
	if (flag == true) {
		cout << "YES" << endl;
		dfsPost(root);
		for (int i = 0; i < n; ++i) {
			if (i != 0)
				cout << " ";
			cout << post[i];
		}
	}

	//not BST
	else {
		//invert BST
		root = invertBST(root);
		//judge
		pre.clear();
		dfs(root);
		bool flag = true;
		for (int i = 0; i < n; ++i) {
			if (vec[i] != pre[i]) {
				flag = false;
				break;
			}
		}
		if (flag == true) {
			cout << "YES" << endl;
			dfsPost(root);
			for (int i = 0; i < n; ++i) {
				if (i != 0)
					cout << " ";
				cout << post[i];
			}
		}
		else
			cout << "NO";
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值