【笨方法学PAT】1099 Build A Binary Search Tree (30 分)

一、题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

二、题目大意

给出一棵二叉搜索树(给出每个结点的左右孩子),且已知根结点为0,求并且给出应该插入这个二叉搜索树的数值,求这棵二叉树的层序遍历。

三、考点

BST

四、注意

1、使用vector<struct node>保存树的结构;

2、对输入从小到大排序,获得中序遍历;

3、根据中序遍历,反向求得树节点的数据;

4、使用queue得到层次遍历。

五、代码

#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
using namespace std;
int n;
struct node {
	int val;
	int left=-1, right=-1;
};
vector<node> tree;
vector<int> in,level;
int index = 0;

void dfs(int root) {
	if (root >= n)
		return;
	if(tree[root].left!=-1)
		dfs(tree[root].left);
	tree[root].val = in[index++];
	if(tree[root].right!=-1)
		dfs(tree[root].right);
	return;
}
int main() {
	//read
	cin >> n;
	tree.resize(n);

	//read and build tree
	for (int i = 0; i < n; ++i) {
		int a, b;
		cin >> a >> b;
		if (a != -1)
			tree[i].left = a;
		if (b != -1)
			tree[i].right = b;
	}

	in.resize(n);
	for (int i = 0; i < n; ++i)
		cin >> in[i];


	//sort
	sort(in.begin(), in.end());

	//dfs
	dfs(0);

	//level
	queue<int> que;
	que.push(0);
	while (!que.empty()) {
		int root = que.front();
		level.push_back(tree[root].val);
		que.pop();
		if (tree[root].left != -1)
			que.push(tree[root].left);
		if (tree[root].right != -1)
			que.push(tree[root].right);
	}

	//output
	for (int i = 0; i < n; ++i) {
		if (i != 0)
			cout << " ";
		cout << level[i];
	}

	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值