【笨方法学PAT】1071 Speech Patterns (25 分)

一、题目

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

二、题目大意

题目大意是找出句中出现次数最多的单词,并输出。。

三、考点

STL

四、注意

1、使tolower变小写,注意分词的方式;

2、使用map<string,int>计数。

五、代码

#include<iostream>
#include<string>
#include<unordered_map>
using namespace std;
int main() {
	//read
	string s;
	getline(cin, s);

	//solve
	unordered_map<string, int> un_map;
	for (int i = 0; i < s.length(); ++i) {
		if (isalnum(s[i])) {
			string t = "";
			while (i < s.length() && isalnum(s[i])) {
				s[i] = tolower(s[i]);
				t += s[i];
				i++;
			}
			if (un_map.find(t) == un_map.end())
				un_map[t] = 1;
			else
				un_map[t]++;
		}
	}

	//find the max
	int max = 0;
	string max_s;
	for (auto it = un_map.begin(); it != un_map.end(); ++it) {
		if (it->second > max) {
			max = it->second;
			max_s = it->first;
		}
		else if (it->second == max) {
			if (it->first < max_s) {
				max_s = it->first;
			}
		}
	}

	//output
	cout << max_s << " " << max << endl;

	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值