【笨方法学PAT】1138 Postorder Traversal (25 分)

一、题目

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

二、题目大意

前序中序转后序。

三、考点

树的遍历

四、注意

1、常规操作,注意序号不要混淆了;

2、尽量选择第二种方法,先建树,然后进行后续操作,以不变应万变。

五、代码

#include<iostream>
#include<vector>
using namespace std;
vector<int> pre, in,post;

void findRoot(int pl, int pr, int il, int ir) {
	if (pl > pr)
		return;
	int index = il;
	while (index<ir&&in[index] != pre[pl])
		index++;

	//left
	findRoot(pl + 1, index-1-il+pl+1, il, index - 1);

	//right
	findRoot(pr-(ir-index-1), pr, index + 1, ir);

	post.push_back(pre[pl]);
}

int main() {
	//read
	int n;
	cin >> n;
	pre.resize(n), in.resize(n);
	for (int i = 0; i < n; ++i)
		cin >> pre[i];
	for (int i = 0; i < n; ++i)
		cin >> in[i];

	findRoot(0, n-1, 0, n-1);

	cout << post[0] << endl;

	system("pause");
	return 0;
}

六、笨方法

#include<iostream>
#include<vector>
using namespace std;
vector<int> pre, in,post;

struct node {
	int val;
	struct node *left, *right;
};

node* buildTree(int pl, int pr, int il, int ir) {
	if (pl > pr)
		return NULL;
	node *root = new node;
	root->val = pre[pl];
	root->left = root->right = NULL;
	int index = il;
	while (il <= ir && in[index] != pre[pl])
		index++;
	root->left = buildTree(pl+1, index-1-il+pl+1, il, index - 1);
	root->right = buildTree(pr-(ir-index-1), pr, index + 1, ir);
	return root;
}

void dfs(node *root) {
	if (root == NULL)
		return;
	dfs(root->left);
	dfs(root->right);
	post.push_back(root->val);
}

int main() {
	//read
	int n;
	cin >> n;
	pre.resize(n), in.resize(n);
	for (int i = 0; i < n; ++i)
		cin >> pre[i];
	for (int i = 0; i < n; ++i)
		cin >> in[i];

	node* root = NULL;
	root=buildTree(0, n - 1, 0, n - 1);

	dfs(root);

	cout << post[0] << endl;

	system("pause");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值