【未完成】【笨方法学PAT】1060 Are They Equal (25 分)

一、题目

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

二、题目大意

科学计数法。

三、考点

string

四、注意

1、最后一个测试点没有通过;

2、参考:https://www.liuchuo.net/archives/2289

五、代码

#include<iostream>
#include<string>
using namespace std;

int n, m;

string getString(string s) {
	string t = "0.", s1, s2;
	int i = 0, k;
	bool flag_dot = false;
	for (i = 0; i < s.length(); ++i) {
		if (s[i] == '.') {
			flag_dot = true;
			break;
		}
	}
	s1 = s.substr(0, i);
	k = i;
	if (flag_dot == true) {
		s2 = s.substr(i + 1);
		s1 += s2;
	}

	i = 0;
	while (i < s1.length() && s1[i] == '0') {
		i++;
		k--;
	}
	s1 = s1.substr(i);


	if (n >= s1.length()) {
		t += s1;
		for (int i = 0; i < n - s1.length(); ++i)
			t += '0';
	}
	else {
		for (int i = 0; i < n; ++i)
			t += s1[i];
	}

	t = t + "*10^" + to_string(k);

	return t;
}

int main() {
	//read
	cin >> n;
	m = n;
	string s1, s2;
	cin >> s1 >> s2;

	//solve
	s1 = getString(s1);
	s2 = getString(s2);

	//output
	if (s1 == s2)
		cout << "YES " << s1 << endl;
	else
		cout << "NO " << s1 << " " << s2 << endl;

	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值