Food Delivery ZOJ3469 区间dp

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person’s coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one’s Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people’s Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output

55
可以很明显看出是区间dp,困难的是要找出转移公式,发现如果区间的话最后的点需要确定在i点还是j点,所以列出dp[i][j][2]

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<stack>
#include<vector>
#include<cmath>
#include<queue>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define m(a) memset(a,0,sizeof(a))
#define mm(a) memset(a,-1,sizeof(a))
#define mi(a) memset(a,0x3f3f3f3f,sizeof(a))
struct node{
    int x,b;
}a[1005];
int cmp(node x,node y){
    return x.x<y.x;
}
int n,v,b,r,num[1005],dp[1005][1005][2];
int Delay(int l,int r)
{
    if(l==0){
        return num[r];
    }
    if(l>r)
        return 0;
    return num[r]-num[l-1];
}
int main(){
    while(cin>>n>>v>>b){
        for(int i=1;i<=n;i++)
            cin>>a[i].x>>a[i].b;
        a[0].x=b,a[0].b=0;
        sort(a,a+n+1,cmp);
        for(int i=0;i<=n;i++)
            if(a[i].x==b)r=i;
        num[0]=a[0].b;
        for(int i=1;i<=n;i++)
            num[i]=num[i-1]+a[i].b;
        mi(dp);
        dp[r][r][0]=dp[r][r][1]=0;
        for(int i=r;i>=0;i--){
            for(int j=r;j<=n;j++){
                if(i==j)continue;
                int qq=Delay(0,i-1)+Delay(j+1,n);
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(qq+a[i].b)*(a[i+1].x-a[i].x));
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(qq+a[i].b)*(a[j].x-a[i].x));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(qq+a[j].b)*(a[j].x-a[i].x));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(qq+a[j].b)*(a[j].x-a[j-1].x));
            }
        }
        cout<<min(dp[0][n][0],dp[0][n][1])*v<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
项目:用 JavaScript 编写的《小鸡快跑》游戏 小鸡快跑游戏是一个 javascript 项目。这是一款简单而有趣的游戏,你可能将它列入你的愿望清单中。这款游戏主要包含 javascript 和一些 CSS,以使其看起来很漂亮。这款游戏与著名的谷歌浏览器离线游戏恐龙跑者非常相似。 游戏玩法 游戏玩法简单有趣。你所要做的就是控制你的小鸡,跳过障碍物。这只鸡的名字叫“Pepper”。在这里,你必须让 Pepper 跳起来,并尽量避开即将到来的威胁。控制键是 W、空格键或向上箭头键。 当你继续游戏时,游戏速度通常会以更快的速度增加。试着按下控制按钮跳得更高,这样 Pepper 就可以跳得更高,以避开障碍物。当你最终撞到障碍物时,你终于可以查看你的得分了。此外,你还可以在社交媒体上分享你的得分。 总的来说,这款游戏玩起来相当有趣。此外,作为一名 程序员,它能让你以某种方式更轻松、更完美地提高你的程序编写能力。这款游戏纯粹是用 javascript 制作的。游戏开发过程中没有使用任何类型的框架。 您可以通过查看下面的图片滑块来查看我们的项目 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值